port mirroring en Cisco

El port mirroring es una fucnión que suelen tener casi todos los router's grandes y que permite copiar todo el tráfico de un puerto a otro puerto. Lo que hace es una copia exacta de todos los paquetes para que, por ejemplo, la nueva interfaz tenga un IDS, como puede ser snort, que esté comprobando todo el tráfico de red. Esto permite analizar el tráfico de red sin que por ello afecte al tráfico o rendimiento de la red, ya que se maneja una copia.
Cisco no podía ser menos y nos ofrece la posibilidad de realizar port mirroring sobre una interfaz y mandar todo el tráfico a otra de las interfaces. Se recomienda que las interfaces tengan la misma velocidad, o que el interfaz origen sea más lento que el interfaz destino. Para configurar el port mirroring por lo tanto:
cisco> interface GigabitEthernet0/1
 switchport
 switchport access vlan 3
 switchport mode access
 spanning-tree portfast

cisco> interface GigabitEthernet0/2
 switchport
 switchport access vlan 3
 switchport mode access
 spanning-tree portfast

cisco> monitor session 1 source interface GigabitEthernet 0/1

cisco> monitor session 1 destination interface GigabitEthernet 0/2

Ahora comprobamos que el mirroring se hizo correctamente así,
cisco> show monitor detail

Session 1
---------
Type              : Local Session
Source Ports      :
    RX Only       : None
    TX Only       : None
    Both          : Gi0/1
    Source VLANs      :
    RX Only       : None
    TX Only       : None
    Both          : None
Source RSPAN VLAN : None
Destination Ports : Gi0/2
    Encapsulation : Native
          Ingress : Disabled
Filter VLANs      : None
Dest RSPAN VLAN   : None


No hay comentarios :

Publicar un comentario

Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

Últimos comentarios